Login
Username:

Password:

Remember me



Lost Password?

Register now!
Main Menu
Who's Online
1 user(s) are online (1 user(s) are browsing Forum)

Members: 0
Guests: 1

more...
   All Posts (TK-313)




Re: Non-latin encodings

Joined:
2012/11/24 4:30
From Voronezh, Russia
Group:
Member
Posts: 6
Offline
I seem to be missing something. In Zune I have font settings for Windows, Listviews and NListviews. I have set all these to 1251-enabled fonts, as well as Magellan's IconDisplay and ListerDisplay, but the tabs and small frame captions remain illegible. Where else should I look?

Posted on: 5/14 3:19
Transfer the post to other applications Transfer


Re: Non-latin encodings

Joined:
2012/11/24 4:30
From Voronezh, Russia
Group:
Member
Posts: 6
Offline
I'm sorry to bump this thread after such a long time, but is UTF support in the systen at least considered? I don't want to sound mean, but it would be very nice to be able to change locale without having to switch all fonts in the system.

Speaking of fonts, could someone help identify the setting for the font on the small captions and tabs (see screenshot)? Because I fail to find it so far.

Attach file:



jpg  scr1.jpg (353.93 KB)
3685_5af8e4acd970b.jpg 1920X1080 px

Posted on: 5/13 18:27
Transfer the post to other applications Transfer


Re: Non-latin encodings

Joined:
2012/11/24 4:30
From Voronezh, Russia
Group:
Member
Posts: 6
Offline
Hooray, amigamaniac's advice helped me teach SimpleEditor and NoWinED Russian, thanks) Didn't work for Cinnamon, however, it seems to be using its own font set and keeps crashing whenever I try to scroll down the list.

Anyway, changing the locale proved to be quite an obscure and non-intuitive process that makes "setting up a printer in OS/2 in 7 steps" look rather pale. Paolone, PLEASE, could this all be at least properly described in the manual? Or, even better, scripted to take effect once the locale is chosen? I mean that I may or may not like the preset Russian fonts, but not having them preset at all, like now, is really frustrating.

Posted on: 2012/12/3 6:52
Transfer the post to other applications Transfer


Re: Non-latin encodings

Joined:
2012/11/24 4:30
From Voronezh, Russia
Group:
Member
Posts: 6
Offline
Problem appears to be solved for OWB. Would the project's author include in the manual the point that to use OWB with languages other than English you have to download extra fonts via Font Downloader, which is in OWB's drawer?

Posted on: 2012/11/30 6:33
Transfer the post to other applications Transfer


Re: Non-latin encodings

Joined:
2012/11/24 4:30
From Voronezh, Russia
Group:
Member
Posts: 6
Offline
Well, it IS possible to set the default charset to UTF-8, but that doesn't help. System-wide Unicode support could really help things a lot...

By the way, to go and change the locale I had to make 9 steps. Can't they be scripted to take effect when, say, the user picks "Russia" in the country list?

Posted on: 2012/11/24 10:15
Transfer the post to other applications Transfer


Non-latin encodings

Joined:
2012/11/24 4:30
From Voronezh, Russia
Group:
Member
Posts: 6
Offline
Hello, All!

I seem to have some font/encoding problem. Being a Russian, I need cyrillics support to feel at home in a system. In Icaros I have done the following:

- in Locale Preferences set the country to Russia, preferred language to Russian, default charset to Amiga-1251
- in Input Preferences turned on layout switching, redefined the hotkey, set alternative language to Russian
- in Font Preferences set the Icons and Screen fonts to XHelvetica_Amiga-1251 and System font to XEN_Amiga-1251

And here goes nothing! Well, not absolutely nothing - I can type in Russian in Editor (but not SimpleEditor or Cinnamon Writer or NoWinED), read Russian-language webpages (but this is available in any locale) and see a few (very, very few) system messages in Russian. That's it, and for everything else (like writing text in OWB, many system messages, buttons, etc., any text editor other than Editor) I get something illegible like âîò òàêàÿ õðåíü. The question is, will this (at least some of it) be fixed in 1.5 or maybe some patch?

Posted on: 2012/11/24 5:17
Transfer the post to other applications Transfer



 Top




Search
Top Posters
1 paolone
paolone
4439
2 magorium
magorium
4095
3 nikolaos
nikolaos
4078
4 phoenixkonsole
phoenixkonsole
3942
5 deadwood
deadwood
2917
6 ncafferkey
ncafferkey
2807
7 mazze
mazze
2222
8 clusteruk
clusteruk
2112
9 damocles
damocles
1789
10 BSzili
BSzili
1516
© 2004-2018 AROS Exec