Login
Username:

Password:

Remember me



Lost Password?

Register now!
Main Menu
Who's Online
1 user(s) are online (1 user(s) are browsing Forum)

Members: 0
Guests: 1

more...

Browsing this Thread:   1 Anonymous Users



(1) 2 3 4 »


(ic)AROS (xmas ed) - installing on hardware, ELF header to small ...

Joined:
2007/2/15 13:20
From Sweden
Group:
Member
Posts: 670
Offline
I was playing around with the ICAros xmas ed, I tried both hosted version on both Windows and Linux...

I had severe problems to install on Windows 10 but did finally.

On Linux everything everything worked as excpected, no problems at all...

However, I thought I would try to install on HD as well and run in native mode, so first i burnt the DVD and booted right into the live mode, tested sound, it worked, tested network, found a driver that allowed internet access, don't know about the graphics (I assume it is VESA mode though).

Anyhow, I took my old AROS drive, SSD and put it in my machine. in liveCD I opened HDToolbox to find out the device number, and started the installer, which first wiped the old Aros install rebooted and let me continue to install, I choose to install everything.

Here I got a lot of errors when installing, Installer could not locate this or that different files several times during the process, my action was to skip that file at the time being. The last error was about installer could not locate OWB (note uppercase) in the dialog. However when I checked in the destination drawer, the OWB where there just in smaller case (owb).

I also choose to install grub onto the same HD as the ICAros went to in my case unit 6 as my main boot linux and win is on unit 0 then in BIOS I choose to use unit 6 as my boot drive.

Now I get a boot error saying the ELF header or something similar is to small, and I am stuck, does anyone have a slight idea to what could be wrong? and how to fix it?

Posted on: 1/20 13:46
Transfer the post to other applications Transfer


Re: (ic)AROS (xmas ed) - installing on hardware, ELF header to small ...

Joined:
2007/2/15 13:20
From Sweden
Group:
Member
Posts: 670
Offline
I have a second question, how well does AROS (Icaros) work with DVD RW media?

Is it possible that the ArOS could modify files on that media on the fly?, personaly I doubt that, but I have to ask.

After doing the testing and the install stuff in previous post, I got from DVDBoot errors like disk not found and boot script error first at one occurance then later on multiple errors in script.

In Linux and Windows the drive where present tough with all files on it.

I changed to a write once DVD but have been unsuccseful so far to install AROS again as Installer can't find the drive anymore. Do AROS need a drive on the first unit on the PC hardware or is it up to me?

Posted on: 1/21 5:58
Transfer the post to other applications Transfer


Re: (ic)AROS (xmas ed) - installing on hardware, ELF header to small ...

Joined:
2004/4/7 4:26
Group:
Member
Posts: 4365
Offline
Some spare hints and tips:

1. you seem to have followed correctly installation steps, unluckily, your machine has a quite complex configuration and I can't tell exactly how to fix the boot issues

2. AROS can't change dvd±rw filesystems on the fly, nor it can do it by mistake. If files disappeared from the media, it might depend on the quality or conservation state of the optical support.

3. please take a clean dvd±rw disc and burn Icaros Desktop at the LOWEST speed your writer/software allows. I generally use this tip when server drives can't find this or that file on a Windows installation DVD the first time.

4. Never ever try installing a new AROS system on a drive which had been formatted by a (very) old release. Disalignment may happen on the filesystem.

Posted on: 1/21 9:59
_________________
p.bes
Icaros Desktop AROS distribution mantainer
Transfer the post to other applications Transfer


Re: (ic)AROS (xmas ed) - installing on hardware, ELF header to small ...

Joined:
2005/2/1 19:32
Group:
Member
Posts: 499
Offline
Quote:

paolone wrote:
4. Never ever try installing a new AROS system on a drive which had been formatted by a (very) old release. Disalignment may happen on the filesystem.


oh, that's interesting - I'm having harddisk errors from time to time (see http://aros-exec.org/modules/newbb/vi ... hp?topic_id=10169&forum=1 ), and I cant remember precisely, but I might have installed AROS on already existing partitions. I did always format them, though.
can you tell me a bit more about "disalignment"?

Posted on: 1/21 12:44
_________________
http://amigaalive.de
Transfer the post to other applications Transfer


Re: (ic)AROS (xmas ed) - installing on hardware, ELF header to small ...

Joined:
2004/4/7 4:26
Group:
Member
Posts: 4365
Offline
AFAIK there had been changes between pre 2.0 sfs and afterwards. Making newer system running itchy on old volumes.

Posted on: 1/21 12:57
_________________
p.bes
Icaros Desktop AROS distribution mantainer
Transfer the post to other applications Transfer


Re: (ic)AROS (xmas ed) - installing on hardware, ELF header to small ...

Joined:
2004/10/30 17:13
From Ireland
Group:
Member
Posts: 2648
Offline
There were bugs in the partitioning software previously. I'm not aware of significant changes to SFS.

It would help with debugging to get the exact error messages (e.g. from a screenshot). It sounds like they are reported by GRUB.

Posted on: 1/21 14:48
_________________
...
Transfer the post to other applications Transfer


Re: (ic)AROS (xmas ed) - installing on hardware, ELF header to small ...

Joined:
2005/2/1 19:32
Group:
Member
Posts: 499
Offline
@paolone:
"version L:sfs-handler" tells me: 1.84
using nightly of 2016-11-21
is this the SFS version you're referring to?
since when is there a version 2.xx? should it be in latest nightlies?

@ncafferkey:
the errors I'm referring to are Wanderer-requesters, "read error... DH1:... disk is in an invalid state..." (or similar), and I get two different ones: a larger one with some info (track/sector/...), and a smaller one with just the error message ("read error... DH1:..." or something) and a line or two of info. I'll take a screenshot next time.

Posted on: 1/21 14:58
_________________
http://amigaalive.de
Transfer the post to other applications Transfer


Re: (ic)AROS (xmas ed) - installing on hardware, ELF header to small ...

Joined:
2007/2/15 13:20
From Sweden
Group:
Member
Posts: 670
Offline
well in my case when it comes to read errors, it is randomly, works sometimes but most often not, one thing is that some procedure take a while, and then when DVD is not spinning it seems like before it is accessible again the system thinks the drive is missing.

I have tried about 10 times now with two different DVD types and with different results, DVD+RW, DVD+R DL, none of them is reliable, start to think I need to change the DVD drive.

I have removed everything not neccessary, a PCI Card to get IDE drives, removed main HD´s just keeping the DVDRom and target HD.

Now I am trying to install to HD via virtualbox and then try to boot it native. at time being there is no installation errors, but the DH0: partition will not be bigger then around 7GB according to HDToolbox, and I can´t figure out how to change that.


[Late Edit]
Yea, it worked I could boot natively, but got io errors on drive randomly "General Device failure" The disk is in an unreadable format

error code = 30
io_Command = 49152
io_ <stuff>

and all drawer icons became blue and lying down and files became like white small paper sheets.

strangely, when booting into Windows and using Virtualbox to access the same drive and boot up into the same drive, there is no error at all...

Posted on: 1/21 15:47

Edited by azvareth on 2017/1/21 16:16:51
Transfer the post to other applications Transfer


Re: (ic)AROS (xmas ed) - installing on hardware, ELF header to small ...

Joined:
2004/10/30 17:13
From Ireland
Group:
Member
Posts: 2648
Offline
@azvareth

The symptom of the optical drive not spinning up again has been seen with ahci.device before. Are your drives SATA? Can you try them in PATA mode?

@romancer

I really meant azvareth's errors.

Posted on: 1/21 18:32
Transfer the post to other applications Transfer


Re: (ic)AROS (xmas ed) - installing on hardware, ELF header to small ...

Joined:
2004/3/29 9:54
From Scotland "The Cold"
Group:
Member
Posts: 2024
Offline
Quote:

ncafferkey wrote:
@azvareth

The symptom of the optical drive not spinning up again has been seen with ahci.device before. Are your drives SATA? Can you try them in PATA mode?


It happens with any AHCI devices sadly.

Posted on: 1/21 19:58
_________________
Click to see original Image in a new window
Transfer the post to other applications Transfer



(1) 2 3 4 »



You can view topic.
You cannot start a new topic.
You cannot reply to posts.
You cannot edit your posts.
You cannot delete your posts.
You cannot add new polls.
You cannot vote in polls.
You cannot attach files to posts.
You cannot post without approval.

[Advanced Search]


Search
Top Posters
1 paolone
paolone
4365
2 magorium
magorium
4095
3 phoenixkonsole
phoenixkonsole
3893
4 nikolaos
nikolaos
3694
5 deadwood
deadwood
2923
6 ncafferkey
ncafferkey
2648
7 mazze
mazze
2214
8 clusteruk
clusteruk
2111
9 Kalamatee
Kalamatee
2024
10 damocles
damocles
1789
© 2004-2017 AROS Exec