Login
Username:

Password:

Remember me



Lost Password?

Register now!
Main Menu
Who's Online
1 user(s) are online (1 user(s) are browsing Forum)

Members: 0
Guests: 1

more...

Browsing this Thread:   1 Anonymous Users



« 1 (2) 3 »


Re: abi v.1 test

Joined:
2007/4/16 6:26
From Norway
Group:
Member
Posts: 3623
Offline
Kalamatee: thank you :)


Here is what I got. With abi v.1 as said DOpus does not start with my DELL Latitude D520 but works with ACER aspire one.
The same goes with Janus-UAE on abi v.0
This has nothing to do with abi v.0 vs v.1 it is simply something that computer don't like in a few programs.
When I start AROS both on abi v.0 and v.1 with the DELL computer I get some dma error, IRQ error 28 or something very hard to see at the boot log on screen. Is there a way to log this info ?

Posted on: 1/29 2:00

Edited by nikolaos on 2017/1/29 2:31:33
Edited by nikolaos on 2017/1/29 2:32:13
Edited by nikolaos on 2017/1/29 2:35:02
_________________
www.aspireos.com
Transfer the post to other applications Transfer


Re: abi v.1 test

Joined:
2007/4/16 6:26
From Norway
Group:
Member
Posts: 3623
Offline
I get message all the time poping up using owb.

Then crash.

https://postimg.org/image/wbpcddp4v/

Posted on: 1/29 7:29
_________________
www.aspireos.com
Transfer the post to other applications Transfer


Re: abi v.1 test

Joined:
2016/8/16 0:09
Group:
Member
Posts: 97
Offline
Quote:
nikolaos wrote:
When I start AROS both on abi v.0 and v.1 with the DELL computer I get some dma error, IRQ error 28 or something very hard to see at the boot log on screen. Is there a way to log this info ?

add debug=memory to grubline and let grub boot Aros. When Aros has booted, open up a shell and use bifteck to make a dump.

Posted on: 1/29 9:27
Transfer the post to other applications Transfer


Re: abi v.1 test

Joined:
2007/4/16 6:26
From Norway
Group:
Member
Posts: 3623
Offline
orimagmi: The part you say about biftek I don't get.
I start biftek then I get output window with info: IconList__MUIM_HandleEvent: IDCMP_NEWSIZE

Posted on: 1/29 10:32
_________________
www.aspireos.com
Transfer the post to other applications Transfer


Re: abi v.1 test

Joined:
2004/10/30 17:13
From Ireland
Group:
Member
Posts: 2511
Offline
Quote:

nikolaos wrote:
orimagmi: The part you say about biftek I don't get.
I start biftek then I get output window with info: IconList__MUIM_HandleEvent: IDCMP_NEWSIZE


Is that all that appears? I would expect a lot more (in fact it sounds more like Sashimi output).

I presume your Dell is using PATA. Have you tried ATA=32bit,nodma etc.?

Posted on: 1/29 10:44
Transfer the post to other applications Transfer


Re: abi v.1 test

Joined:
2016/8/16 0:09
Group:
Member
Posts: 97
Offline
I agree with ncafferkey there.

bifteck should be invoked from shell and certainly does not open a window (unless it must be a shell window).

It is a shell tool and only dumps data located from the debug location.

It is therefor important to 'catch' that debug data as soon as possible (before it gets overridden). You should invoke bifteck at the first opportunity before doing anything else.

You can use the TO option to store bifteck output to a file or you can pipe it manually to a file.

Posted on: 1/29 13:13
Transfer the post to other applications Transfer


Re: abi v.1 test

Joined:
2007/4/16 6:26
From Norway
Group:
Member
Posts: 3623
Offline
I used biftek not sashimi. Starting the program I get output window with the info I wrote before.
I tried with nodma but did not change anything.

Edit: I started biftek from shell. That changed things a bit :) Now I have some info :)

[HiddStorage] Storage_Init()
[HiddStorage] Storage_Init: initialised
[HiddSystsem] Systsem_Init()
[HiddSystsem] Systsem_Init: initialised
[PCIDevice] WARNING: Interrupt line is not assigned! Device may freeze or malfunction at use!
[BattClock] Got RTC century offset 0x32 from ACPI
[HWGfx] csd @ 0x010d9df8
[HWGfx] Instantiating...
[HWGfx] returning 0x010dc144
[HWGfx] csd @ 0x010d9df8
[HWGfx] returning 0x010dc144
[driver_init] Memory driver object 0x010de884
[driver_init] Planar bitmap cache 0x010de9d0
[driver_init] GC cache 0x010de9d0
[Vesa] HwInit: No Vesa information from the bootloader. Failing
Exit PCParUnit_Init=1
[ATA ] Approximate number of iterations per 100 nanoseconds: 5
[ATA00] ata_Identify: Unit info: Hitachi HTS541612J9SA00 / SB2D11E4HZK7VB / SBDOC74P
[ATA02] ata_Identify: Unit info: TSSTcorp DVD+/-RW TS-L632D / / DE03
[ATA02] IRQ: IO status 51, DMA status 0
[ATA02] IRQ: ERROR 20
[ATA02] IRQ: DMA Failed.
[ATA02] IRQ: IO status 51, DMA status 0
[ATA02] IRQ: ERROR 20
[ATA02] IRQ: DMA Failed.
[ATA02] IRQ: IO status 51, DMA status 0
[ATA02] IRQ: ERROR 20
[ATA02] IRQ: DMA Failed.
[ATA02] IRQ: IO status 51, DMA status 0
[ATA02] IRQ: ERROR 20
[ATA02] IRQ: DMA Failed.
[ATA02] IRQ: IO status 51, DMA status 0
[ATA02] IRQ: ERROR 20
[ATA02] IRQ: DMA Failed.
[ATA02] IRQ: IO status 51, DMA status 0
[ATA02] IRQ: ERROR 20
[ATA02] IRQ: DMA Failed.
[ATA02] IRQ: IO status 51, DMA status 0
[ATA02] IRQ: ERROR 20
[ATA02] IRQ: DMA Failed.
[ATA02] IRQ: IO status 51, DMA status 0
[ATA02] IRQ: ERROR 20
[ATA02] IRQ: DMA Failed.
[ATA02] IRQ: IO status 51, DMA status 0
[ATA02] IRQ: ERROR 20
[ATA02] IRQ: DMA Failed.
[ATA02] IRQ: IO status 51, DMA status 0
[ATA02] IRQ: ERROR 20
[ATA02] IRQ: DMA Failed.
[ATA02] IRQ: IO status 51, DMA status 0
[ATA02] IRQ: ERROR 20
[ATA02] IRQ: DMA Failed.
[ATA02] IRQ: IO status 51, DMA status 0
[ATA02] IRQ: ERROR 20
[ATA02] IRQ: DMA Failed.
[ATA02] IRQ: IO status 51, DMA status 0
[ATA02] IRQ: ERROR 20
[ATA02] IRQ: DMA Failed.
[I2C] Init

[GMA] Attempting to detect connected monitor
[GMA] Probing GPIOA
[GMA] I2C device found
[GMA] lvds Enabled
[GMA] GetSync: 1024 1048 1184 1344
768 771 777 806
[GMA] InitMode 640x480x32 @ 59Hz
[GMA] LoadState 640x480x32
[GMA] panelfitter ON
G45_PFIT_CONTROL=80002668
G45_PFIT_PGM_RATIOS=0
i915 gallium init OK
[drm(INFO)] Failed detecting card for VendorID: 0x10de
[ATI] Init
[ATI] No supported cards found
intuition.decor: offsets titleobj = 548, menuobj = 552, winobj = 556
[AROSTCP] net0 is now online.
[GMA] InitMode 1024x768x32 @ 43Hz
[GMA] InitMode 1024x768x32 @ 43Hz
[IntelG45] HIDD_INTELG45_SwitchToVideoMode bitmap:23b2b28
[GMA] LoadState 1024x768x32
[GMA] panelfitter OFF
[SmartTrash]ToolType LEFTEDGE=550
[SmartTrash]ToolType TOPEDGE =195
[SmartTrash]ToolType ICONNAME=Wastebasket
[SmartTrash]ToolType ICONFILE=SYS:Trashcan
[SmartTrash]Using Default Garbage icon
G45_PFIT_CONTROL=80002668
G45_PFIT_PGM_RATIOS=0



Posted on: 1/29 14:10
_________________
www.aspireos.com
Transfer the post to other applications Transfer


Re: abi v.1 test

Joined:
2007/4/16 6:26
From Norway
Group:
Member
Posts: 3623
Offline
I started DOpus from shell and ran Sashimi.

I got from the output window:

Floppy Unit 0 is a 1.44MB drive

CTRL + C can not quit the program and as you already know nothing happen and system get slow.

Edit: got it working :) Had to add floppy=disabled

I run AROS from usb-storage device. Why is this happening ?

Anyway thank for the help guys.

Posted on: 1/29 14:20
_________________
www.aspireos.com
Transfer the post to other applications Transfer


Re: abi v.1 test

Joined:
2007/4/16 6:26
From Norway
Group:
Member
Posts: 3623
Offline
In ports when I open the game Gem Drop X!
I get this CON: SDL_SetError: music parameter was NULL

Noticed that I had to open ahi.prefs and click test sound and after that sound was working in Gem Drop X! but still the CON: window with the SDL_Seterror message.

Posted on: 1/29 14:44
_________________
www.aspireos.com
Transfer the post to other applications Transfer


Re: abi v.1 test

Joined:
2010/8/30 7:20
Group:
Member
Posts: 770
Offline
this is the debug coming from sdl. it should be silenced once the problems with sdl are taken carre of. currently there is one problem with audio thread on 68k, x86 was working allright last it tried, not sure about x64.

Posted on: 1/29 15:50
Transfer the post to other applications Transfer



« 1 (2) 3 »



You can view topic.
You cannot start a new topic.
You cannot reply to posts.
You cannot edit your posts.
You cannot delete your posts.
You cannot add new polls.
You cannot vote in polls.
You cannot attach files to posts.
You cannot post without approval.

[Advanced Search]


Search
Top Posters
1 paolone
paolone
4154
2 magorium
magorium
4095
3 phoenixkonsole
phoenixkonsole
3870
4 nikolaos
nikolaos
3623
5 deadwood
deadwood
2915
6 ncafferkey
ncafferkey
2511
7 mazze
mazze
2192
8 clusteruk
clusteruk
2055
9 Kalamatee
Kalamatee
1940
10 damocles
damocles
1789
© 2004-2014 AROS Exec