Login
Username:

Password:

Remember me



Lost Password?

Register now!
Main Menu
Who's Online
3 user(s) are online (1 user(s) are browsing Forum)

Members: 2
Guests: 1

amiga, mordesku, more...

Browsing this Thread:   1 Anonymous Users



(1) 2 »


Testing AROS 64-bit

Joined:
2007/4/16 6:26
From Norway
Group:
Member
Posts: 3693
Offline
Live-CD booted fine on my laptop.

I made partitions on usb-drive. Worked fine.

Rebooted AROS.
Started the installer and selected to install system and use work partition and format.

Everything ready and click procceed and screen went black.
Hard crash, rebooted by itself. Tried this several times. Same problem.

Edit: This is not the same laptop as I installed AROS abi v.1 32-bit yesterday. The laptop I installed to yesterday is not 64-bit capable. I can try to install on my big-box tomorrow or sunday.

Posted on: 11/3 9:14

Edited by nikolaos on 2017/11/3 9:39:04
Edited by nikolaos on 2017/11/3 9:40:28
_________________
www.aspireos.com
Transfer the post to other applications Transfer


Re: Testing AROS 64-bit

Joined:
2010/8/30 7:20
Group:
Member
Posts: 947
Offline
you might try to catch the serial log on your hardware, aros boot logging is enabled by default (nightly). you must just set an appropriate baudrate. some developer might be able to help you upon that.

Posted on: 11/3 12:30
Transfer the post to other applications Transfer


Re: Testing AROS 64-bit

Joined:
2007/4/16 6:26
From Norway
Group:
Member
Posts: 3693
Offline
wawa: That is not so easy on real hardware.

I tried other laptop now. Kind of same problem.
I open the installer and format the usb-drive. Reboots and when I try to open the installer it does not start or open a window. I took out the usb-drive and then the installer open but if I insert the usb-drive again it is not recognized but the installer. I tried another thing. Since I created the AROS partitions I wanted to try to format them but that was just blocked when I hit the procceed format button. AROS did not crash but the format window got stuck and could not do anything.

All this worked fine with AROS abi v.1 32-bit

Neil: You there ;)

Posted on: 11/8 11:34
_________________
www.aspireos.com
Transfer the post to other applications Transfer


Re: Testing AROS 64-bit

Joined:
2010/8/30 7:20
Group:
Member
Posts: 947
Offline
im probably not able to help, especially i dont compile 64 bit and im not familiar with aros installation process. i always simply formatted a drive and then copied the content of iso over it. how do you proceed? do you use installer or install_aros? sorry for being dumb in this respect..

Posted on: 11/8 13:48
Transfer the post to other applications Transfer


Re: Testing AROS 64-bit

Joined:
2007/4/16 6:26
From Norway
Group:
Member
Posts: 3693
Offline
I don't compile aros either. Just download the night build. Burn the ISO to optical disk.
Boot the disk. After booted you have to create AROS partitions on some kind of storage device if you like to use it serious to save and delete stuff etc.
The creation of partitions must be done inside AROS and that works fine. Can not use FAT or NTFS file system with AROS. Has to be FFS or SFS for system.
Problem is after the partitions are created AROS don't like to install the system to it. The installer simply does not open. Something is blocking it.

Posted on: 11/8 14:08
_________________
www.aspireos.com
Transfer the post to other applications Transfer


Re: Testing AROS 64-bit

Joined:
2010/8/30 7:20
Group:
Member
Posts: 947
Offline
so you use installer utility?
if you run it from shell you probably get "required argument missing"?
if you specify a device, it will want you to specify a script?

Posted on: 11/8 17:06
Transfer the post to other applications Transfer


Re: Testing AROS 64-bit

Joined:
2010/8/30 7:20
Group:
Member
Posts: 947
Offline
now, btw the path to a test script was wrong anyway. commited a fix..

Posted on: 11/8 17:34
Transfer the post to other applications Transfer


Re: Testing AROS 64-bit

Joined:
2010/8/30 7:20
Group:
Member
Posts: 947
Offline
i have corrected some small error in installaros debug here and might enable debug for it as well as install-grub2, which is probably what you need for native hardware. but i dont have means here to test it. so the question is if there is anyone who can catch serial log on this and an able developer who can actually review it, before i commit.

Posted on: 11/9 2:04
Transfer the post to other applications Transfer


Re: Testing AROS 64-bit

Joined:
2007/4/16 6:26
From Norway
Group:
Member
Posts: 3693
Offline
Thank you wawa. If you can compile install aros I could always test it. Be sure to not confuse installer and install aros. It is two different things.

Where is sashimi by the way?

nikosidis(at)gmail.com

Posted on: 11/9 3:41

Edited by nikolaos on 2017/11/9 4:39:54
_________________
www.aspireos.com
Transfer the post to other applications Transfer


Re: Testing AROS 64-bit

Joined:
2010/8/30 7:20
Group:
Member
Posts: 947
Offline
Quote:

nikolaos wrote:

Where is sashimi by the way?



in /Developer/Debug

edit:
just enabled debug on installaros and install-grub2. should be in next nightly, whenever it is available.
grub2 contains a lot of ULONG vars, a number of which might need to be replaced with IPTRs for 64bit, but its not for me to tell.

Posted on: 11/9 4:40
Transfer the post to other applications Transfer



(1) 2 »



You can view topic.
You cannot start a new topic.
You cannot reply to posts.
You cannot edit your posts.
You cannot delete your posts.
You cannot add new polls.
You cannot vote in polls.
You cannot attach files to posts.
You cannot post without approval.

[Advanced Search]


Search
Top Posters
1 paolone
paolone
4359
2 magorium
magorium
4095
3 phoenixkonsole
phoenixkonsole
3892
4 nikolaos
nikolaos
3693
5 deadwood
deadwood
2923
6 ncafferkey
ncafferkey
2646
7 mazze
mazze
2214
8 clusteruk
clusteruk
2109
9 Kalamatee
Kalamatee
2024
10 damocles
damocles
1789
© 2004-2017 AROS Exec