Login
Username:

Password:

Remember me



Lost Password?

Register now!
Main Menu
Who's Online
1 user(s) are online (1 user(s) are browsing Forum)

Members: 0
Guests: 1

more...

Browsing this Thread:   1 Anonymous Users



« 1 (2)


Re: AROS 8bit JPEG Images

Joined:
2013/1/15 6:16
From Marseille
Group:
Member
Posts: 200
Offline
i'm on native 2.2.1 (last update).

I replaced the original "jpeg.datatype" by the ones in 1.5.2 dvd.
I renamed "jpeg.library" to "jpeg.library.old"

i "saved as" the blackpanther picture in the ram disk, and double clicked on it. Wanderer tool (i don't know wich tool icaros is using to open pictures) opens it nicely, and it shows correctly.

Under Zuneview it shows correctly too.

Under OWB i get this (picture attached). As you can see, the picture area is blank.

Under OWB, when you double click on a picture, from aros-exec forum (this page), it usually shows the picture into a new tab.
For the "desktop" picture, no problem, it works.
For the black panther one, it is even not reacting to the double click, it does nothing.

So now, i have a problem with OWB only.
Do you have this old 1.5.2 jpeg.library i can try ?

Attach file:



png  toto.png (246.07 KB)
3727_5a2ba008723da.png 521X803 px

Posted on: 12/9 0:33
_________________
Loved Amiga from the first second. DMOS RULEZ!
IcAROS native SB Audigy 2- RTL8169 network card - nVidia nvs 380 -- some nice articles on aros, music, and amiga here : http://amiga.thewetmachine.net/icaros-box/
Transfer the post to other applications Transfer


Re: AROS 8bit JPEG Images

Joined:
2012/4/16 8:41
From Brindisi (Italy)
Group:
Member
Posts: 1129
Offline
Made small Test, installed IcarOS 2.2 on VMware Player and the image can be seen perfectly.
Even on OS3 (AFA OS), the images can be seen well, from the screensh you can see the difference:



Attach file:



jpg  IcarOS-2.2.jpg (185.00 KB)
3226_5a2c2cfcf0950.jpg 1032X837 px

jpg  AFA OS.jpg (272.28 KB)
3226_5a2c2d4e397fd.jpg 1024X768 px

Posted on: 12/9 10:37
_________________
https://www.plagimusicali.net/
Transfer the post to other applications Transfer


Re: AROS 8bit JPEG Images

Joined:
2017/5/2 17:15
From California, United States
Group:
Member
Posts: 164
Offline
@oan3,

We have to be sure what we are talking about here. The jpeg library is different than the jpeg picture datatype. The jpeg picture datatype is located in a hidden drawer in AROS partition. The drawer is called Classes/DataTypes. The datatype itself is called jpeg.datatype and that is what MultiView and presumably ZuneView uses. (Icaros Default Image Viewer with double-click is MultiView).

If you replaced the jpeg library itself with the one from Icaros 1.5.2 then that's a different scenario. I have the iso for 1.5.2 on one of my hard disks. I'll try it when I get a chance to see what the differences are in jpeg files.


Posted on: 12/9 11:49
Transfer the post to other applications Transfer


Re: AROS 8bit JPEG Images

Joined:
2013/1/15 6:16
From Marseille
Group:
Member
Posts: 200
Offline
@miker

Hi ! i know a little about the differences between datatypes and libraries.
I tried different scenarios to try to fix my problem. So i tried replacing jpeg datatypes as well as jpeg libraries. Just to try.
1)At the begining, with the original icaros 2.2.1 (as well as 2.0), i could not get the "blackpanther" jpeg showing well in zuneview and in owb (both show blank picture).
2)So i replaced jpeg datatypes and the problem is fixed under zuneview, but not in OWB.
3)I would like to replace the jpeg library but i could not get a jpeg library on the 1.5.2 DVD i have... maybe it's located outside /libs/... or in /storage/ ? So if you have this file, i would be happy to get it.
If necessary, I'll reinstall 1.5.2 to get the file, but i would have liked not to do this...
4)One more information : with the same graphic card (nvidia nvs380 -not 600 as i said on my first post-) but on an other computer (an old, slow, and ugly dell optiplex 755), there is no problem with this jpeg file...

Posted on: 12/11 22:14
_________________
Loved Amiga from the first second. DMOS RULEZ!
IcAROS native SB Audigy 2- RTL8169 network card - nVidia nvs 380 -- some nice articles on aros, music, and amiga here : http://amiga.thewetmachine.net/icaros-box/
Transfer the post to other applications Transfer


Re: AROS 8bit JPEG Images

Joined:
2010/8/30 7:20
Group:
Member
Posts: 979
Offline
Quote:

oan3 wrote:
@miker

So i replaced jpeg datatypes and the problem is fixed under zuneview, but not in OWB.


are you talking of odyssey or aros owb?

with aros owb, you can choose if images are handled internally or via datatypes in the preferences. if they are handled internally then i suppose they are being loaded via statically linked respective libs.

edit: from your screenshot it seems you really refer to aros owb. try to play with the image loader settings i mentioned. set them to datatype to test datatypes.

Posted on: 12/12 1:25
Transfer the post to other applications Transfer



« 1 (2)



You can view topic.
You cannot start a new topic.
You cannot reply to posts.
You cannot edit your posts.
You cannot delete your posts.
You cannot add new polls.
You cannot vote in polls.
You cannot attach files to posts.
You cannot post without approval.

[Advanced Search]


Search
Top Posters
1 paolone
paolone
4366
2 magorium
magorium
4095
3 phoenixkonsole
phoenixkonsole
3895
4 nikolaos
nikolaos
3705
5 deadwood
deadwood
2923
6 ncafferkey
ncafferkey
2668
7 mazze
mazze
2216
8 clusteruk
clusteruk
2111
9 Kalamatee
Kalamatee
2024
10 damocles
damocles
1789
© 2004-2017 AROS Exec