Login
Username:

Password:

Remember me



Lost Password?

Register now!
Main Menu
Who's Online
21 user(s) are online (17 user(s) are browsing Forum)

Members: 1
Guests: 20

Yanosh, more...

Browsing this Thread:   1 Anonymous Users



(1) 2 »


Finally my AROS-full-compliant machine is ready! Let's install Icaros and have fun ;)

Joined:
2009/10/13 1:12
From Poland - Italy
Group:
Member
Posts: 466
Offline
Hi,

I was lurking around for a while, but then recently I managed to find the missing pieces for my Aros native machine, so I want to share my "funny" experience ;)

My PC was already almost AROS-Compatible, being an AMD Athlon 1600+ on a ASUS A7V266 mobo equipped with ATI-Radeon 9800 and Sound-Blaster Live (EMU10K1), what I added to complete is the NIC (Realtek 8139) and an unused 20Gb ATA hard-disk to dedicate at Icaros.

SO LET'S GO! Finally I will be able to surf the word-wideness-of-the-web with OWB scrolling pages at full speed!!!

(In this days I also made some benchmark tests of AROS running in different virtual-environments, but since the feeling of "trying to run swamped in a pond" I decided to do my best to make it run native. I will publish the benchmark results in another post, I think they are interesting!)

Yeah, let's go native! Insert Icaros 1.2.0 DVD, wipe-disk, reboot, format, install... and here the issues started:

- randomly I got error messages about DMA errors, not sure if it was about hard-drive failures or DVD-RAM reading failures, I just clicked "Retry" button everytime, and seems that I got Icaros installed (It took a while anyway :-S )
The hard-disk was used before with no problems formatted as a windows NTFS partition, was full of data and never had a bad sector or writing/reading issue on windows, while the DVD-RAM already gave me some problems, so I thought DVD was failing and didn't care about this errors...

Installation finished, removed DVD, reboot... configure network, start OWB: Generating fonts cache... pls wait... "Error launching OWB" :( Ouch..

Increase the stack same error (I will provide a screenshot and other info in another post)

"Maybe the new release and Icaros 1.2.1 update will make it work" I tought... yeah! Let's try! But how to download the update if I can't use OWB? Hmmmm...

And here starts the real fun:

- Let's try with WGET! I saw a WGET-Gui icon in Amistart>Software>Newtork group... oh, pity GUI is in Polish :/ Well I understand a bit of Polish lang so let's put the source URL, the destination, et voila: WGET-Gui got stuck trying to something-only-god-knows and there was no "X" or CTRL-C way to stop it... in an attempt to kill it with SCOUT only got a complete AROS freezed system :(

2nd try:

- Let's download it on my Linux laptop and then put it on a USB pendrive! Then insert the USB-Fat32-Pendrive on Icaros: Got a message from Trident that a new device was recognized, good... then nothing. I admit I'm ignorant on AROS-USB support, but shouldn't a memory devices be mounted automatically and an icon appear on the desktop? No? How should I use USB Pendrives on AROS?? Sorry if I missed some tutorials, I'm digging now in AROS-ICAROS PDFs, AROS-EXEC forum and Paolone's blog, but nothing useful found so far :(

3rd try:

- Icaros has a nice FTP server starting automatically! Let's transfer via FTP! On Linux: $ftp 192.168.1.50 , anonymous, bin , put Icaros-bla-bla.tgz ...waiting for transfer to complete... wait... wait... please wait.... don't be impatient... wait... wait... (no progress bar), chcking network stats on linux, no one single bit moving :/ Hmmm... Icaros? Are you there? No :( Only 3mb transferred then TCP stuck, no connectivity, reboot needed :((( Another tentative in the same way I got transfered 4 mb then stuck again.

4th try:

- We have as well an FTP client on Icaros! And my Linux box is an HTTP/FTP server, so let's do opposite way: open Marrano-FTP and connect to my FTP-Linux-Server! Yeah, until "open Marrano-FTP client" it worked, everything else not :( Seems that to connect to a FTP server you have to add it on a "address-book", ok but I can't save the address book, the Log-Tab shows an "error saving something" ... no useful information found with Snoopy-n-Sashimi... Yes I saw a post on Aros-Exec that suggest to copy Marrano-FTP executable and launch from RAM: to create some settings file then copy this file to hard-disk then it should work.. but in my case it didn't :(



Hmm.. Mumble Mumble... no OWB, no FTP-server, no FTP-client, no USB... I could burn a CD with this iso file on my Linux box.. but it's on an old laptop without CD-burner :( Maybe Icaros have just a command-line wget that was launched by this Polish-GUI? Wanderer>Shell>wget BINGO!

5th try: So, wget http://www.icarosdesktop.com/updates/Icaros-blabla.tgz ...it works! Ehm.. whaaat? 20 minutes ETA? 50Kb/sec? Hey!!! I just downloaded it from Linux at 250Kb/sec from the same link! I can't wait another 20 minutes! Is already 2 hours I'm here trying :)))

Ok, let's download the fu$#!n .tgz update with WGET but from my Linux-WWW-Server...


6th try: wget http://192.168.1.120/Icaros-blabla.tgz .. 200Kb sec! EEEEK!! On a 100Mb-LAN?! Are you kidding? And also again this "DMA error message", now I know there are issues with the hard-drive .. or with AROS-and-my-hard-drive :/

Wait.. let's try to launch wget from RAM-drive. Transferring... speed 7Mb/sec... damn slow but I could finally get the .tgz transfered on ICAROS! Now, let's unpack it with Zune-Arc, done... let's launch LUA and select the .iso.. Again "DMA errors" :( Now after a couple of "Retry" Icaros freezed and I had to reboot... :(((

Ok, I'm stubborn and I want to try again! I got full Icaros installed clicking one million of "Retry" on DMA errors, I will install the update same way.

But... after the reboot, open RAM: where is my .tgz? and my .iso? YOU STUPID! IT's RAM!!! :(((((( Again wget, again ZuneArc, now in AROS: and then another million "retry" to finish the update.

Reboot...

Wow! I have a nice red-arrow with a shadow :)) Cool, really! And OWB? Click... generating font cache... Unable to execute OWB :(

Ok, enough for today it's about 3-AM so better take some sleep... and let's think positive! I learnd many things today:

- Icaros/AROS is still an ALPHA release. Remember!
- Networking needs improvements in terms of speed and stability
- QA is needed in Icaros in order to polish-clean many programs included (I will do my best to help Paolone in this way)
- AROS don't like very much my type of hard-disk or controller or both... needed some investigation...
- We need another browser for "emergency" cases if OWB doesn't start... With a simple-html web browser you could post on Aros-Exec asking for help...
- On Saturday night there are much better things to than staying in front of PC until 3-AM ;)))


Any suggestion / idea / tips or trick to solve OWB and DMA-Errors issues?? I will add anyway more info about this in other posts.


And thanks if you are reading until here :) Hope you enjoyed :P


--LuKe

P.S. This long story is not to blame Icaros/AROS but to give my feedback as "Mr. Everybody user" on it. I'm an Amiga fan like you and I hope this testings can contribute to improve Icaros/AROS.

Posted on: 2010/3/28 6:52
Transfer the post to other applications Transfer


Re: Finally my AROS-full-compliant machine is ready! Let's install Icaros and have fun ;)

Joined:
2008/10/11 22:43
Group:
Member
Posts: 508
Offline
Be great to know how other VIA chipset motherboard owners get on with booting and installing (is -nodma required).

What make of hard drive and DVD are you using? Are you able to verify the DVD burn was okay? A 20GB drive might be getting near to the end of its life? That DVD drive misreading could also be a problem?

I have something similar happen where if a CD is burnt with drive won't necessarily work in another. Try again in another burner and it works. Always catches me out.

Another option is to test using a USB pendrive but not until DVD reading issues solved.
I wonder if Paolo upcoming USB pendrive install will work independently of a DVD burn?

Jeff.

Posted on: 2010/3/28 7:32
Transfer the post to other applications Transfer


Re: Finally my AROS-full-compliant machine is ready! Let's install Icaros and have fun ;)

Joined:
2009/10/24 10:31
From Finland
Group:
Member
Posts: 275
Offline
I have DMA problems too ( via chipset )
only ata=nodma grub option works.

other problems are IMHO related to DMA and corrupted disk.

Posted on: 2010/3/28 7:39
_________________
"Programming is an art form that fights back."
Transfer the post to other applications Transfer


Re: Finally my AROS-full-compliant machine is ready! Let's install Icaros and have fun ;)

Joined:
2009/10/13 1:12
From Poland - Italy
Group:
Member
Posts: 466
Offline
Thanks jeffrey1138 and Sami!

I'm pretty sure the hard-disk has no problems, yes it's not new, but the day before using with aros was full of data and never showed a read-error on Windows.

Maybe all the mess is due to some VIA chipset issues that corrupted data installing AROS? This might explain OWB not starting due to corrupted system libraries/whatever?

It's a nice theory.. okay, next "AROS night" I will repeat all installation with -nodma, but I'm really scared about hard-disk performance then :(

And this will bring me again to the start: Need to change mobo to make the PC AROS-compliant... :/


Other question: Do you know if we have a "checkdisk" tool in AROS? To check filesystem errors? (no need to check sectory-by-sector).

--LuKe

Posted on: 2010/3/28 8:04
Transfer the post to other applications Transfer


Re: Finally my AROS-full-compliant machine is ready! Let's install Icaros and have fun ;)

Joined:
2008/10/11 22:43
Group:
Member
Posts: 508
Offline
I would not worry about losing DMA performance - small price to pay for lack of DMA errors. Replace ATA=32bit with ATA=nodma not -nodma - my typing error...

Jeff.

Posted on: 2010/3/28 8:30

Edited by jeffrey1138 on 2010/3/28 8:52:11
Transfer the post to other applications Transfer


Re: Finally my AROS-full-compliant machine is ready! Let's install Icaros and have fun ;)

Joined:
2004/10/30 17:13
From Ireland
Group:
Member
Posts: 2072
Offline
ATA=32bit,nodma can also be used, which is usually a lot faster than just nodma.

Posted on: 2010/3/28 12:33
Transfer the post to other applications Transfer


Re: Finally my AROS-full-compliant machine is ready! Let's install Icaros and have fun ;)
Guest_
Got no Problems with this Hardware Configuration!
Icaros runs fine on a Partition of a SATA Harddisk!
(Icaros shows only 120 MB of Chip Mem although Radeon 9600 seems to have 256 MB)


Motherboard:
CPU Type AMD Athlon 64, 2200 MHz (11 x 200)
Motherboard Name MSI K8MM-V (MS-7142) (3 PCI, 1 AGP, 2 DDR DIMM, Audio, Video, LAN)
Motherboard Chipset VIA K8T800Pro, AMD Hammer
System Memory 1024 MB (PC3200 DDR SDRAM)
BIOS Type Award (10/12/06)
Communication Port Kommunikationsanschluss (COM1)
Communication Port Kommunikationsanschluss (COM2)
Communication Port Druckeranschluss (LPT1)

Display:
Video Adapter ATI Radeon 9600/9550/X1050 Series - Secondary (256 MB)
Video Adapter ATI Radeon 9600/9550/X1050 Series (256 MB)
3D Accelerator ATI Radeon 9600 (RV350)
Monitor Plug und Play-Monitor [NoDB] (933GH3XY01097)

Multimedia:
Audio Adapter Creative SB Live! 5.1 Digital (SB0220) Sound Card

Storage:
IDE Controller VIA Bus Master IDE Controller - 0571
IDE Controller VIA Serial ATA Controller - 3149
SCSI/RAID Controller SCSI/RAID Host Controller
Disk Drive WDC WD5000AAVS-00ZTB0 (465 GB, IDE)
Disk Drive STM3320418AS (298 GB, IDE)
Optical Drive TSSTcorp CDDVDW SH-S222A

Partitions:
C: (NTFS) 35000 MB (22738 MB free)
D: (NTFS) 476929 MB (11422 MB free)
E: (NTFS) 149997 MB (103008 MB free)
Total Size 646.4 GB (134.0 GB free)

Input:
Keyboard HID-Tastatur
Mouse HID-konforme Maus

Network:
Network Adapter Realtek RTL8169/8110 Family Gigabit Ethernet NIC

Posted on: 2010/3/28 19:48
Transfer the post to other applications Transfer


Re: Finally my AROS-full-compliant machine is ready! Let's install Icaros and have fun ;)

Joined:
2009/10/13 1:12
From Poland - Italy
Group:
Member
Posts: 466
Offline
Well well...

Hi QBit1000! Happy thay you got your Aros runnig :) But your mb chipset is not the same as mine.

My beloved (grrrr) A7V266 has a VIA KT266A VT8366A + VT8233 chipset (http://active-hardware.com/english/reviews/mainboard/a7v266-e.htm)

And I think we can put it on the black-list of not working hardware on http://en.wikibooks.org/wiki/Aros/Pla ... port#NOT_WORKING_HARDWARE
(by now I mean, for the future... I have a strong trust in aros-developers ;) )

Here are a couple of screenshots from tests with ATA=32bit,nodma / ATA=nodma

(At the moment the same hard-drive is hosting Ubuntu 9.04 without any read/write issue so I would exclude it as part of the issue)

Awaiting for some fix in aros ata or to buy a new PC (maybe imica/aresone? :) ) I will go back to my VBOX/Qemu Icaros.

Ah, no, installing on USB is not an option here, my mobo doesn't boot from USB pendrives :(

Cheers and thanks all for support.

--LuKe

Attach file:



jpg  ata_32bit-nodma.JPG (0.00 KB)


jpg  ata_nodma.JPG (0.00 KB)


Posted on: 2010/3/29 3:33
Transfer the post to other applications Transfer


Re: Finally my AROS-full-compliant machine is ready! Let's install Icaros and have fun ;)

Joined:
2007/6/29 13:14
Group:
Member
Posts: 41
Offline
Is it possible you can send me the links in eBay for these two cards: Sound card and Ethernet card? Thanks in advance.

Posted on: 2010/4/15 18:46
Transfer the post to other applications Transfer


Re: Finally my AROS-full-compliant machine is ready! Let's install Icaros and have fun ;)

Joined:
2008/10/11 22:43
Group:
Member
Posts: 508
Offline
Have a read of this thread

http://aros-exec.org/modules/newbb/vi ... t_id=27708#forumpost27708


Sound Cards

search "ebay soundblaster live" and avoid all 24 bit cards

referring to this page

http://en.wikibooks.org/wiki/Aros/Pla ... ndblaster_Live_and_Audigy


Network is a little more work but most recommend 3com see here

http://en.wikibooks.org/wiki/Aros/Platforms/x86_Network_support


Jeff.

Posted on: 2010/4/15 19:49

Edited by jeffrey1138 on 2010/4/15 20:24:10
Transfer the post to other applications Transfer



(1) 2 »



You can view topic.
You cannot start a new topic.
You cannot reply to posts.
You cannot edit your posts.
You cannot delete your posts.
You cannot add new polls.
You cannot vote in polls.
You cannot attach files to posts.
You cannot post without approval.

[Advanced Search]


Search
Top Posters
1 paolone
paolone
3668
2 nikolaos
nikolaos
3467
3 phoenixkonsole
phoenixkonsole
3039
4 magorium
magorium
3005
5 deadwood
deadwood
2342
6 ncafferkey
ncafferkey
2072
7 mazze
mazze
2068
8 clusteruk
clusteruk
2050
9 damocles
damocles
1769
10 Kalamatee
Kalamatee
1714
© 2004-2014 AROS Exec