Login
Username:

Password:

Remember me



Lost Password?

Register now!
Main Menu
Who's Online
24 user(s) are online (20 user(s) are browsing Forum)

Members: 1
Guests: 23

lellonapoli, more...

Browsing this Thread:   1 Anonymous Users





Icaros on Lenovo X61 Tablet

Joined:
2012/3/4 11:47
From Germany
Group:
Member
Posts: 135
Offline
Hello!

Since my Amigas are in repair, I tried AROS first in Virtualbox and now on my Lenovo X61 TabletPC. I installed the Icaros 1.3.3 DVD Distro from the Ultrabase DVD Drive (no USB-DVD) to a 16 GB USB Stick with 4 SFS Partitions, but only the first (DU0:) is used. All files are installed on the boot partition. After this I installed the patches 1-3 manually using DirectoryOpus, the LiveUpdater made problems the first time. AmiBridge was installed with the Amiga Forever 2011 Plus CD.

The system works fine, though I don't know where the most programs are located, never used 3.5 or 3.9. In AmigaOS 3.1 you have to create your setup all alone, so it's easier to find your progs ;) The Intel GMA 3100 chipset is working in native resolution (1400x1050x32), screen dragging also works. Trackpoint is also working.

So, what's not working:

- Intel HDA Audio
- Atheros Mini-PCI-E WLAN card
- AROS reboot

First to the easiest thing: If I use the 'reboot' command or select the option in Wanderer's menu, the system will crash. Let's say it's freezed, no 'Software Failure' message or a Guru (if this still exists in AROS). The option to restart the Computer is working.


Intel HDA Audio. First, I never had an Amiga audio card and don't know how to use AHI. I've got the hdaudio files V6.17 which were installed from an AROS update, I didn't copy something myself. I followed the readme file, selected hdaudio:HiFi 16 bit stereo++ and used a frequency of 44.1 kHz, but playing a test tone didn't work. Also other applications don't have sound. Here are the data from the PCItool:

Description: Multimedia Audio
Vendor Name: Intel Corporation
Product Name: 82801H (ICH8 Family) HD Audio Controller
Subsystem: Lenovo : Thinkpad T61
VendorID: 0x8086 DeviceID: 0x284b RevisionID: 0x03
Class: 0x04 Subclass: 0x03 Interface: 0x00
ROM Base: N/A ROM Size: N/A IRQ: 11 (B)

Vendor and Device ID are added in the hdaudio config file.


Atheros WLAN. I read from Atheros USB WLAN sticks, so I hoped to get a working driver. My Atheros WLAN adapter (official IBM) is a Mini-PCI-Express card. It's the first time I experiment with network on an Amiga-compatible OS. I created a static configuration with custom DNS servers etc. as in my Windows installations on the Thinkpad (and except the IP also on my Powerbook G4). I used the atheros5000.device in AROS, Encryption is WPA with passwort, hidden no, Ad-hoc yes. The speed is limited to 54 Mbit/s because of the old Airport of my Powerbook G4. But it's still not working, I get no connection. After changes I also get the message 'Network can't restarted', but the settings will be saved. Because AROS reboot doesn't work, I have to switch off the Thinkpad and reboot new, but it's still not working. Here are the data from the PCItool:

Description: Network Ethernet
Vendor Name: Atheros Communications
Product Name: AR5212 802.11 abg NIC
Subsystem: Lenovo : IBM Thinkpad 11a/b/g Wireless LAN Mini Express Adapter (AR5BXB6)
VendorID: 0x168x DeviceID: 0x1014 RevisionID: 0x01
Class: 0x02 Subclass: 0x00 Interface: 0x00
ROM Base: N/A ROM Size: N/A IRQ: 11 (A)

It should be a driver or installation issue, I could even connect to my WiFi network with my Archos 605 WiFi multimedia player.


These would be the main problems. Is there a way to create a boot log file? I could see some interrupt errors during the short time text is displayed. The curious thing is, the default PCI settings in the Thinkpad's BIOS are all assigned to IRQ 11, I set them to automatic.

Is there an AROS keymap editor? My Thinkpad X61 has a Laptop keyboard with differs from usual keyboards, and my most used keyboard layout is from OSx86, so I have to create a complete new keyboard layout.

Future things: Because the X61t is a TabletPC, it would be great to get touch sensitivity. It features a Wacom Penabled type display, that means it acts like a serial Wacom tablet. There are some drivers for serial tablets in the Aminet, I think I used the Wacom_150 driver for my Artpad II on my A1200 and my A4000T. It worked system-wide, so you could control the complete OS with the pen. It would be cool to get an AROS version from it, in the time of TabletPC's it would be cool if there was an Amiga-based version, too. The Wacom Penabled function is still a standard, Wacom provides drivers even for Win 7 64bit. On OS X or OSx86 you can use TabletMagic for serial Wacom Tablets, it also has a driver for TabletPCs (search in YouTube for X61 Tablet OSx86). Tablet PC support would also require an On-Screen-Keyboard.

How good is support for Bluetooth and Firewire yet? Is there any kind of laptop battery control?

Greets, RC.


P.S.: Too bad the Pen couldn't tickle the Kitty, it's only laying around :( Click twice on the pic if your browser scales it, it's rather big.

P.P.S.: The small blob on the right side is the 16 GB USB stick. The ExtreMemory Snippy are really recommandable, they're small and fast, I got more than 10 MB/s with the 32 GB version (in OSx86). They're available up to 32 GB or as 8 GB Plus version with MicroSD slot.

Attach file:



jpg  aros_tablet.jpg (982.82 KB)
3140_4f54fd228e0dd.jpg 2592X1944 px

Posted on: 2012/3/5 9:44
Transfer the post to other applications Transfer


Re: Icaros on Lenovo X61 Tablet

Joined:
2010/1/8 10:07
Group:
Member
Posts: 1212
Offline
Hi matey and welcome ...


if Vendor and Device ID are in the hdaudio config file than add QUERY on top hdaudio config file if that helps..

QUERY
0x8086, 0x2668
0x8086, 0x269A
0x8086, 0x27D8
0x8086, 0x284B
0x8086, 0x293E
0x8086, 0x3A3E
0x8086, 0x3A6E
0x8086, 0x3B56
0x8086, 0x811B
etc

Posted on: 2012/3/5 9:54
Transfer the post to other applications Transfer


Re: Icaros on Lenovo X61 Tablet

Joined:
2012/3/4 11:47
From Germany
Group:
Member
Posts: 135
Offline
Sorry, didn't work. What for a 'Test Tone' could I expect, some kind of beep or a real music sample?

The settings for Music Unit and Channels 0-3 are actually:

Frequency 44.1 kHz
Channels Music Unit: greyed out
Channels Unit 0-3: 1
Volume: all +0.0 dB
Monitor: all -34.5 dB
Gain: all +0.0 dB
Input: Mic1
Output: Line (greyed out)

These are the input/output devices:

Thinkpad outputs:

Internal Speakers
Line Out

Thinkpad inputs:

Microphone
internal Microphone
*No Line-in*
Probably CD-Audio and Mixer

Docking station outputs:

Docking station speakers, probably used by Line Out
Line Out

Docking station inputs:

Microphone
*No Line-In*

If I add the docking station, I get a 'crack' sound from the station's speakers. I also get this crack when I connect external speakers to the Line-Out ports (Docking station and Thinkpad). But that's all, the internal speakers of the Thinkpad don't work at all :(

I also tested MPlayer, I only get a crack sound over external speakers when starting an MP3, but that's all.

Posted on: 2012/3/5 10:30
Transfer the post to other applications Transfer


Re: Icaros on Lenovo X61 Tablet

Joined:
2004/10/30 17:13
From Ireland
Group:
Member
Posts: 2071
Offline
Quote:

RC_tech wrote:
So, what's not working:

- Intel HDA Audio


Not all HDA codec chips work yet. If you've tried both with and without QUERY, there probably isn't anything you can do.

Quote:

- Atheros Mini-PCI-E WLAN card


To get some debugging information, please boot without networking enabled and run this command in the shell:

C:WirelessManager atheros5000.device verbose

Quote:

- AROS reboot


This usually doesn't work because not all drivers support it.

Quote:

How good is support for Bluetooth and Firewire yet? Is there any kind of laptop battery control?


There's no support for any of these.

Posted on: 2012/3/5 13:00
Transfer the post to other applications Transfer


Re: Icaros on Lenovo X61 Tablet

Joined:
2004/4/7 4:26
Group:
Member
Posts: 3668
Offline
Hi RC_, I am really curious about the AROS experience on a tablet PC. Anyway, just some suggestions.

1) raise monitor volume in AHI for all devices

2) instead of 'reboot', use 'reboot COLD' instead

3) don't forget to add your network name in network preferences. Other OSes get this information automatically. AROS doesn't.

Posted on: 2012/3/6 5:47
_________________
p.bes
Icaros Desktop AROS distribution mantainer
Transfer the post to other applications Transfer


Re: Icaros on Lenovo X61 Tablet

Joined:
2012/3/4 11:47
From Germany
Group:
Member
Posts: 135
Offline
Woo-hoo, here I'm posting right from OWB :D

I installed icaros Desktop 1.4 today, configured new and WLAN works! I also configured SimpleMail 0.36, receiving mail is possible, sending not. I tried YAM then, here sending and receiving works. Cabled network isn't tested yet, but I haven't used it in Windows yet either.

Reboot also works, no matter from Wanderer's menu or from the Shell. It only creates a distorted, one-half black screen and it takes some time, but it works.

The Amibridge Setup also works, but I can't open the JanusUAE prefs. I also tried it in the Exchange commodity, but it doesn't work.

Something to critize is that a lot of programs don't have a proper translations. It's not because I don't understand English, but it's annyoing that one application is translated, the next one not. Is there somwhere a place to get locale files for Germany?

How is it possible to open programs on screens at startup? The virtual screens are one of the best features of AmigaOS, why makes AROS so less use of it? Problems with graphics drivers and draggable screens?

I also tested it on my AMD Opteron system with ATI graphics, worked directly from the Live DVD. AC97 audio too, network isn't tested. I'm normally using the Marvell LAN port of my board which is not supported from AROS, maybe the nForce port is.


So, the most important feaature would be working Intel HDA audio support for my TabletPC. How does AHI handle other laptops? it has no output selection for internal speakers - well, understandable because an Amiga laptop was never planned.

Posted on: 2012/3/10 11:57
Transfer the post to other applications Transfer






You can view topic.
You cannot start a new topic.
You cannot reply to posts.
You cannot edit your posts.
You cannot delete your posts.
You cannot add new polls.
You cannot vote in polls.
You cannot attach files to posts.
You cannot post without approval.

[Advanced Search]


Search
Top Posters
1 paolone
paolone
3668
2 nikolaos
nikolaos
3467
3 phoenixkonsole
phoenixkonsole
3039
4 magorium
magorium
3000
5 deadwood
deadwood
2342
6 ncafferkey
ncafferkey
2071
7 mazze
mazze
2068
8 clusteruk
clusteruk
2050
9 damocles
damocles
1769
10 Kalamatee
Kalamatee
1714
© 2004-2014 AROS Exec