Login
Username:

Password:

Remember me



Lost Password?

Register now!
Main Menu
Who's Online
1 user(s) are online (1 user(s) are browsing Forum)

Members: 0
Guests: 1

more...

Browsing this Thread:   1 Anonymous Users



(1) 2 3 4 5 »


Quake II

Joined:
2011/9/25 1:23
From Hungary
Group:
Member
Posts: 1506
Offline
Quake II was among the first games I wanted to port to AROS. I started with the classic amiga sources by Hyperion, then I switched to Q2 LNX, then I got fed up. For some reason I just couldn't get it to work. I decided to put the project on hold, and focus on other ones. Yesterday a friend brought Yamagi Quake2 to my attention, which has a neat and clean codebase and a tremendous amount of bugfixes. You can check out its features here: http://www.yamagi.org/quake2
I started working on it this afternoon, and I finally have a working version: http://wizard2k8.uw.hu/quake2.lha

Please bear in mind that this is only a test version, it's likely to have some bugs (the networking seems to be screwed up for example). It also lacks the software renderer, Yamagi got rid of it for some reason. If there's some interest, I will backport Q2 LNX's software renderer.

Posted on: 2012/7/18 14:15
_________________
My AROS&MorphOS ports
Arguments that explain everything... explain nothing.
Transfer the post to other applications Transfer


Re: Quake II

Joined:
2007/4/16 6:26
From Norway
Group:
Member
Posts: 3677
Offline
BSzili: Whow, great work. Just tried it. Very nice :) thx.

I had a crash on exit from the game.

Posted on: 2012/7/18 16:27
_________________
www.aspireos.com
Transfer the post to other applications Transfer


Re: Quake II

Joined:
2011/9/25 1:23
From Hungary
Group:
Member
Posts: 1506
Offline
It always crashes on exit? I had a nice CPU error crash when I started working on it, but none since. A new version is coming soon with (hopefully) fixed networking, and mod support.

Posted on: 2012/7/19 1:37
_________________
My AROS&MorphOS ports
Arguments that explain everything... explain nothing.
Transfer the post to other applications Transfer


Re: Quake II

Joined:
2011/9/17 15:53
From St.Petersburg
Group:
Member
Posts: 157
Offline
It works fine right now, but It needs a lot of stack.

Doesn't crash on exit.

ThAnKs A lOt!

Posted on: 2012/7/19 1:53
Transfer the post to other applications Transfer


Re: Quake II

Joined:
2011/9/25 1:23
From Hungary
Group:
Member
Posts: 1506
Offline
I bet it does, Quake games are quite heavy on the stack, especially the level loading. I uploaded the new version. It includes support for the mission packs, and Quake II CTF. Other mods can be done too, and long as their source is available.
Could someone test the network support for me? In virtualbox it always binds to 0.0.0.0:0 instead of the real address

edit: I almost forgot, you can start mods with quake2 +set game name-of-the-mod

Posted on: 2012/7/19 2:04
_________________
My AROS&MorphOS ports
Arguments that explain everything... explain nothing.
Transfer the post to other applications Transfer


Re: Quake II

Joined:
2011/9/17 15:53
From St.Petersburg
Group:
Member
Posts: 157
Offline
It also works, but it does not show the servers list, speaking about network.

Posted on: 2012/7/19 4:37
Transfer the post to other applications Transfer


Re: Quake II

Joined:
2011/9/25 1:23
From Hungary
Group:
Member
Posts: 1506
Offline
Does it show the correct address in the console, instead of 0.0.0.0? Could you copy the output for me here?
AFAIK the built-in server browser only supports LAN servers, but you can join internet servers with the connect command in the console.

Posted on: 2012/7/19 4:49
_________________
My AROS&MorphOS ports
Arguments that explain everything... explain nothing.
Transfer the post to other applications Transfer


Re: Quake II

Joined:
2011/9/17 15:53
From St.Petersburg
Group:
Member
Posts: 157
Offline
How to check and where to find?

Posted on: 2012/7/19 8:20
Transfer the post to other applications Transfer


Re: Quake II

Joined:
2011/9/25 1:23
From Hungary
Group:
Member
Posts: 1506
Offline
The simplest way would be attaching baseq2/qconsole.log.

Posted on: 2012/7/19 10:36
_________________
My AROS&MorphOS ports
Arguments that explain everything... explain nothing.
Transfer the post to other applications Transfer


Re: Quake II

Joined:
2011/9/17 15:53
From St.Petersburg
Group:
Member
Posts: 157
Offline
Here it is. By the way, it seems I have common problems with network under MorphOS:)

Console initialized.

------- sound initialization -------
Starting SDL audio callback.
SDL audio driver is "AHI".
SDL audio initialized.
Sound sampling rate: 22050
Starting Ogg Vorbis.
OGG_LoadPlaylist: could not open playlist: No such file or directory.
No Ogg Vorbis files found.
Shutting down Ogg Vorbis.
------------------------------------

----- refresher initialization -----
LoadLibrary("ref_gl.so")
Byte ordering: little endian

Input initialized.
Refresher build options:
+ Retexturing support
- Gamma via X11
Refresh: Yamagi Quake II OpenGL Refresher
SDL video driver is "CGX".
setting mode -1: 1024 768
Got 8 bits of stencil.
Using hardware gamma via SDL.

OpenGL setting:
GL_VENDOR: nouveau
GL_RENDERER: Gallium 0.4 on NV4B
GL_VERSION: 2.1 Mesa 7.11
GL_EXTENSIONS: GL_ARB_multisample GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_logic_op GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_copy_texture GL_EXT_polygon_offset GL_EXT_subtexture GL_EXT_texture_object GL_EXT_vertex_array GL_EXT_compiled_vertex_array GL_EXT_texture GL_EXT_texture3D GL_IBM_rasterpos_clip GL_ARB_point_parameters GL_EXT_draw_range_elements GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_separate_specular_color GL_EXT_texture_edge_clamp GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_ARB_multitexture GL_IBM_multimode_draw_arrays GL_IBM_texture_mirrored_repeat GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_transpose_matrix GL_EXT_blend_func_separate GL_EXT_fog_coord GL_EXT_multi_draw_arrays GL_EXT_secondary_color GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_INGR_blend_func_separate GL_NV_blend_square GL_NV_light_max_exponent GL_NV_texgen_reflection GL_NV_texture_env_combine4 GL_SUN_multi_draw_arrays GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_EXT_framebuffer_object GL_EXT_texture_env_dot3 GL_MESA_window_pos GL_NV_packed_depth_stencil GL_NV_texture_rectangle GL_ARB_depth_texture GL_ARB_occlusion_query GL_ARB_shadow GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_window_pos GL_EXT_stencil_two_side GL_EXT_texture_cube_map GL_APPLE_packed_pixels GL_APPLE_vertex_array_object GL_ARB_draw_buffers GL_ARB_fragment_program GL_ARB_fragment_shader GL_ARB_shader_objects GL_ARB_vertex_program GL_ARB_vertex_shader GL_ATI_draw_buffers GL_ATI_texture_env_combine3 GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_MESA_pack_invert GL_ARB_fragment_program_shadow GL_ARB_half_float_pixel GL_ARB_occlusion_query2 GL_ARB_point_sprite GL_ARB_shading_language_100 GL_ARB_sync GL_ARB_texture_non_power_of_two GL_ARB_vertex_buffer_object GL_ATI_blend_equation_separate GL_EXT_blend_equation_separate GL_OES_read_format GL_ARB_color_buffer_float GL_ARB_pixel_buffer_object GL_ARB_texture_rectangle GL_EXT_pixel_buffer_object GL_EXT_texture_mirror_clamp GL_EXT_texture_rectangle GL_EXT_texture_sRGB GL_ARB_framebuffer_object GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_packed_depth_stencil GL_ARB_vertex_array_object GL_ATI_separate_stencil GL_ATI_texture_mirror_once GL_EXT_gpu_program_parameters GL_EXT_texture_env_combine GL_EXT_texture_sRGB_decode GL_OES_EGL_image GL_ARB_copy_buffer GL_ARB_half_float_vertex GL_ARB_map_buffer_range GL_ARB_texture_rg GL_ARB_texture_swizzle GL_ARB_vertex_array_bgra GL_EXT_separate_shader_objects GL_EXT_texture_swizzle GL_EXT_vertex_array_bgra GL_ARB_draw_elements_base_vertex GL_ARB_explicit_attrib_location GL_ARB_fragment_coord_conventions GL_ARB_provoking_vertex GL_ARB_sampler_objects GL_EXT_provoking_vertex GL_ARB_robustness


Probing for OpenGL extensions:
...enabling GL_EXT_compiled_vertex_array
...using GL_EXT_point_parameters
...GL_EXT_shared_texture_palette not found
...using GL_ARB_multitexture
...GL_SGIS_multitexture not found
...using GL_EXT_texture_filter_anisotropic
...using GL_ARB_texture_env_combine
------------------------------------

-------- game initialization -------
LoadLibrary("game.so")
Game is starting up.
Game is baseq2.
------------------------------------

------- server initialization ------
0 entities inhibited.
0 teams with 0 entities.
------------------------------------

==== Yamagi Quake II Initialized ====

*************************************

0.0.0.0:0: client_connect
Dropped frame: 12 > 11
ERROR: UDP_OpenSocket: bind: Address already in use
pinging broadcast...
pinging multicast...
ERROR: UDP_OpenSocket: bind: Address already in use
pinging broadcast...
pinging multicast...
ERROR: UDP_OpenSocket: bind: Address already in use
pinging broadcast...
pinging multicast...
ERROR: UDP_OpenSocket: bind: Address already in use
pinging broadcast...
pinging multicast...
ERROR: UDP_OpenSocket: bind: Address already in use
pinging broadcast...
pinging multicast...
ERROR: UDP_OpenSocket: bind: Address already in use
pinging broadcast...
pinging multicast...
ERROR: UDP_OpenSocket: bind: Address already in use
pinging broadcast...
pinging multicast...
<UNKNOWN KEYNUM> is unbound, hit F4 to set.
<UNKNOWN KEYNUM> is unbound, hit F4 to set.
------- server initialization ------
0 entities inhibited.
0 teams with 0 entities.
------------------------------------


Changing map...
reconnecting...




Installation
Map: base2

pics

maps/base2.bsp

models/weapons/v_blast/tris.md2

models/objects/gibs/sm_meat/tris.md2

models/objects/gibs/arm/tris.md2

models/objects/gibs/bone/tris.md2

models/objects/gibs/bone2/tris.md2

models/objects/gibs/chest/tris.md2

models/objects/gibs/skull/tris.md2

models/objects/gibs/head2/tris.md2

models/monsters/gunner/tris.md2

models/monsters/infantry/tris.md2

models/monsters/soldier/tris.md2

models/objects/laser/tris.md2

models/deadbods/dude/tris.md2

models/items/ammo/shells/medium/tris.

models/items/healing/medium/tris.md2

models/weapons/g_shotg/tris.md2

models/weapons/v_shotg/tris.md2

weapons/v_shotg/flash2/tris.md2

models/items/armor/shard/tris.md2

models/items/ammo/bullets/medium/tris

models/items/ammo/grenades/medium/tri

models/weapons/v_handgr/tris.md2

models/items/healing/large/tris.md2

models/monsters/flyer/tris.md2

models/items/healing/stimpack/tris.md

models/items/armor/jacket/tris.md2

models/objects/debris1/tris.md2

models/objects/debris2/tris.md2

models/objects/debris3/tris.md2

models/objects/barrels/tris.md2

models/weapons/g_shotg2/tris.md2

models/weapons/v_shotg2/tris.md2

models/weapons/g_machn/tris.md2

models/weapons/v_machn/tris.md2

models/objects/gibs/head/tris.md2

models/items/quaddama/tris.md2

images

client 0

sky

OGG_OpenName: '07' not in the list.
<UNKNOWN KEYNUM> is unbound, hit F4 to set.
<UNKNOWN KEYNUM> is unbound, hit F4 to set.
ERROR: UDP_OpenSocket: bind: Address already in use
pinging broadcast...
pinging multicast...
maxclients will be changed for next game.
deathmatch will be changed for next game.
==== ShutdownGame ====
ERROR: UDP_OpenSocket: bind: Address already in use
-------- game initialization -------
LoadLibrary("game.so")
Game is starting up.
Game is baseq2.
------------------------------------

------- server initialization ------
50 entities inhibited.
1 teams with 2 entities.
------------------------------------

Server restarted
Server disconnected, reconnecting
Connecting to localhost...
0.0.0.0:0: challenge
Player connected
0.0.0.0:0: client_connect




Outer Base
Map: BASE1

pics

maps/BASE1.bsp

models/weapons/v_blast/tris.md2

#w_blaster.md2

#w_shotgun.md2

#w_sshotgun.md2

#w_machinegun.md2

#w_chaingun.md2

#a_grenades.md2

#w_glauncher.md2

#w_rlauncher.md2

#w_hyperblaster.md2

#w_railgun.md2

#w_bfg.md2

models/objects/gibs/sm_meat/tris.md2

models/objects/gibs/arm/tris.md2

models/objects/gibs/bone/tris.md2

models/objects/gibs/bone2/tris.md2

models/objects/gibs/chest/tris.md2

models/objects/gibs/skull/tris.md2

models/objects/gibs/head2/tris.md2

models/items/healing/stimpack/tris.md

models/items/ammo/grenades/medium/tri

models/weapons/v_handgr/tris.md2

models/items/armor/jacket/tris.md2

models/weapons/g_bfg/tris.md2

models/weapons/v_bfg/tris.md2

models/items/ammo/cells/medium/tris.m

sprites/s_bfg1.sp2

sprites/s_bfg2.sp2

sprites/s_bfg3.sp2

models/items/armor/combat/tris.md2

models/items/quaddama/tris.md2

models/items/ammo/bullets/medium/tris

models/items/ammo/shells/medium/tris.

models/weapons/g_shotg2/tris.md2

models/weapons/v_shotg2/tris.md2

models/weapons/g_machn/tris.md2

models/weapons/v_machn/tris.md2

models/weapons/g_hyperb/tris.md2

models/weapons/v_hyperb/tris.md2

models/items/ammo/rockets/medium/tris

models/weapons/g_rocket/tris.md2

models/weapons/v_rocket/tris.md2

models/objects/rocket/tris.md2

models/objects/debris2/tris.md2

models/objects/dmspot/tris.md2

models/items/armor/shard/tris.md2

models/items/healing/large/tris.md2

models/items/adrenal/tris.md2

models/items/healing/medium/tris.md2

models/items/silencer/tris.md2

models/objects/gibs/head/tris.md2

models/weapons/g_shotg/tris.md2

models/weapons/v_shotg/tris.md2

images

client 0

sky

OGG_OpenName: '09' not in the list.
Player entered the game
<UNKNOWN KEYNUM> is unbound, hit F4 to set.
<UNKNOWN KEYNUM> is unbound, hit F4 to set.
<UNKNOWN KEYNUM> is unbound, hit F4 to set.
<UNKNOWN KEYNUM> is unbound, hit F4 to set.
<UNKNOWN KEYNUM> is unbound, hit F4 to set.
<UNKNOWN KEYNUM> is unbound, hit F4 to set.
<UNKNOWN KEYNUM> is unbound, hit F4 to set.
<UNKNOWN KEYNUM> is unbound, hit F4 to set.
<UNKNOWN KEYNUM> is unbound, hit F4 to set.
<UNKNOWN KEYNUM> is unbound, hit F4 to set.
<UNKNOWN KEYNUM> is unbound, hit F4 to set.
deathmatch will be changed for next game.
==== ShutdownGame ====
-------- game initialization -------
LoadLibrary("game.so")
Game is starting up.
Game is baseq2.
------------------------------------

------- server initialization ------
0 entities inhibited.
0 teams with 0 entities.
------------------------------------

0.0.0.0:0: client_connect
------- server initialization ------
28 entities inhibited.
1 teams with 2 entities.
------------------------------------


Changing map...
reconnecting...

Posted on: 2012/7/19 11:09
Transfer the post to other applications Transfer



(1) 2 3 4 5 »



You can view topic.
You cannot start a new topic.
You cannot reply to posts.
You cannot edit your posts.
You cannot delete your posts.
You cannot add new polls.
You cannot vote in polls.
You cannot attach files to posts.
You cannot post without approval.

[Advanced Search]


Search
Top Posters
1 paolone
paolone
4346
2 magorium
magorium
4095
3 phoenixkonsole
phoenixkonsole
3891
4 nikolaos
nikolaos
3677
5 deadwood
deadwood
2923
6 ncafferkey
ncafferkey
2631
7 mazze
mazze
2214
8 clusteruk
clusteruk
2103
9 Kalamatee
Kalamatee
2024
10 damocles
damocles
1789
© 2004-2017 AROS Exec