Login
Username:

Password:

Remember me



Lost Password?

Register now!
Main Menu
Who's Online
16 user(s) are online (14 user(s) are browsing Forum)

Members: 0
Guests: 16

more...

Browsing this Thread:   1 Anonymous Users



(1) 2 »


Trouble with hdaudio driver

Joined:
2012/7/30 11:24
Group:
Member
Posts: 8
Offline
Hi

I have an AHI problem on ICAROS.
I don't succeed in output sound on my laptop (specs here: http://www.dooyoo.co.uk/laptops/fujit ... milo-si-1520-21p/details/).
I installed successfully ICAROS on USB stick, but It's impossible to achieve correct audio settings to output sound
As I read in AHI documentation, please find a sashami log as requested...

I hope you'll find useful stuff in it...
Feel free to ask me for additional tests.

Thank you


lspci dump from linux:

00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 3 (rev 02)
00:1d.0 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7-M Family) SATA Controller [AHCI mode] (rev 02)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 02)
01:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
07:08.0 Ethernet controller: Intel Corporation PRO/100 VE Network Connection (rev 02)
07:09.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller
07:09.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 19)
07:09.2 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 0a)
07:09.3 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 05)

Attach file:


log ahi.log Size: 6.29 KB; Hits: 63

Posted on: 2012/8/2 10:23
Transfer the post to other applications Transfer


Re: Trouble with hdaudio driver

Joined:
2004/10/30 17:13
From Ireland
Group:
Member
Posts: 2070
Offline
Sorry, I don't think there's anything you can do until a better version of the driver is released. Your codec chip has the ID 14f1:5045, which means it's a Connexant chip.

Posted on: 2012/8/2 10:43
Transfer the post to other applications Transfer


Re: Trouble with hdaudio driver

Joined:
2012/7/30 11:24
Group:
Member
Posts: 8
Offline
I made additional tests with an headphone and now I hear the audio chart signal of AHI Prefs but sound is very very low :(
However, I set "maximum volume" in tab of AHI Prefs...

Did I miss another setting somewhere ?

Posted on: 2012/8/2 10:56
Transfer the post to other applications Transfer


Re: Trouble with hdaudio driver

Joined:
2004/10/30 17:13
From Ireland
Group:
Member
Posts: 2070
Offline
You probably didn't miss a setting: low volume is a common bug displayed by the driver.

Posted on: 2012/8/2 11:04
Transfer the post to other applications Transfer


Re: Trouble with hdaudio driver

Joined:
2012/7/30 11:24
Group:
Member
Posts: 8
Offline
Ok

Very very bad news...

I hope someone will fix this problem.
Or in worst case, I'll checkout source code and fix it myself... :)

Thank you for your reply

Posted on: 2012/8/2 11:15
Transfer the post to other applications Transfer


Re: Trouble with hdaudio driver

Joined:
2009/6/17 13:30
Group:
Member
Posts: 15
Offline
+1 volumen very very low...

Posted on: 2012/8/2 15:41
Transfer the post to other applications Transfer


Re: Trouble with hdaudio driver

Joined:
2012/7/30 11:24
Group:
Member
Posts: 8
Offline
I dare to write: volume so low that in it's actual state this driver is unusable on my hardware...

Posted on: 2012/8/3 9:28
Transfer the post to other applications Transfer


Re: Trouble with hdaudio driver

Joined:
2004/10/30 17:13
From Ireland
Group:
Member
Posts: 2070
Offline
Quote:

thioroup8 wrote:
I dare to write: volume so low that in it's actual state this driver is unusable on my hardware...


I know I never claimed otherwise.

Posted on: 2012/8/3 11:05
Transfer the post to other applications Transfer


Re: Trouble with hdaudio driver

Joined:
2012/3/4 11:47
From Germany
Group:
Member
Posts: 135
Offline
HDaudio is'nt working on my system, too. It's displayed in AHI prefs but nothing. If I connect a speaker I only hear a small blip on the left channel, that's all. I reduced ENVARC:hdaudio.prefs already to

QUERY
0x8086, 0x284B

Still nothing. Isn't anyone working on this driver? Maybe this would be worth a bounty, because audio is the only important component what's not working on my system.

Posted on: 2012/11/4 18:58
Transfer the post to other applications Transfer


Re: Trouble with hdaudio driver

Joined:
2006/4/7 1:34
Group:
Member
Posts: 472
Offline
I have just successfully tested Icaros 1.4.3 on Fujitsu-Siemens Lifebook E8110 with audio (IntelHD) and 3D support (IntelGMA45). The only missing thing is network. Or is there a driver for IntelPro Wireless?

Here are more details about this laptop: http://www.dooyoo.co.uk/laptops/fujitsu-siemens-lifebook-e8110/

I have no problems with hdaudio volume (I'm using headphones) so far and will test Icaros 1.5.1-01 soon.

Posted on: 2013/2/3 14:55
Transfer the post to other applications Transfer



(1) 2 »



You can view topic.
You cannot start a new topic.
You cannot reply to posts.
You cannot edit your posts.
You cannot delete your posts.
You cannot add new polls.
You cannot vote in polls.
You cannot attach files to posts.
You cannot post without approval.

[Advanced Search]


Search
Top Posters
1 paolone
paolone
3663
2 nikolaos
nikolaos
3467
3 phoenixkonsole
phoenixkonsole
3036
4 magorium
magorium
2993
5 deadwood
deadwood
2342
6 ncafferkey
ncafferkey
2070
7 mazze
mazze
2068
8 clusteruk
clusteruk
2050
9 damocles
damocles
1769
10 Kalamatee
Kalamatee
1714
© 2004-2014 AROS Exec