Login
Username:

Password:

Remember me



Lost Password?

Register now!
Main Menu
Who's Online
1 user(s) are online (1 user(s) are browsing Forum)

Members: 0
Guests: 1

more...

Browsing this Thread:   1 Anonymous Users



(1) 2 »


AROS hosted

Joined:
2012/8/16 12:52
From Sweden
Group:
Member
Posts: 97
Offline
I noticed my AROS (linux hosted) still won't boot. (Funny, it didnt magically fix itself during the holidays).

It seem to me the XServer on Ubuntu 17.10 is the evil part and was wondering if it's possible to setup Aros source/debug on windows (no X) or if i should just try good old Debian.
Could be nice to hack and build in a real IDE .. sometimes.
(and I couldn't find good old "ed" in the AROS Shell so.. )

Overall, i would love to see good up to date developer guides, would definitely support that. i will write them myself If (when) I get everything going.


Posted on: 1/31 10:58
Transfer the post to other applications Transfer


Re: AROS hosted

Joined:
2012/8/16 12:52
From Sweden
Group:
Member
Posts: 97
Offline
Baah, I did a fresh reinstall according to that guide: http://amifreak.ftp.sh/post/setting-up-environment-to-start

But X really hates me and my Ubuntu.

Quote:

[ELF Loader] Code 0xf3a32ccc, Data 0x8d8ed24, Module ram-handler...
[Bootstrap] Entering kernel at 0xf391b000...
XError 8 (Major=73, Minor=0) task = X11
BadMatch (invalid parameter attributes)

Posted on: 1/31 12:00
_________________
www.arosos.se
Transfer the post to other applications Transfer


Re: AROS hosted

Joined:
2009/9/27 22:09
Group:
Member
Posts: 1047
Offline
I don't know if it will help in your situation, but I used the script in Icaros to setup Icaros hosted on Slackware. It was so simple even I could do it

Posted on: 1/31 17:45
Transfer the post to other applications Transfer


Re: AROS hosted

Joined:
2012/8/16 12:52
From Sweden
Group:
Member
Posts: 97
Offline
Sounds real nice! I should try something else then Ubuntu, wouldn't surprise me if they have tinkered with X.
If that's not the problem I don't know, the guide (if it is correct) is easy to follow.

Posted on: 1/31 21:20
_________________
www.arosos.se
Transfer the post to other applications Transfer


Re: AROS hosted

Joined:
2004/4/7 4:26
Group:
Member
Posts: 4375
Offline
Quote:

cavemann wrote:
I don't know if it will help in your situation, but I used the script in Icaros to setup Icaros hosted on Slackware. It was so simple even I could do it


So you can confirm Icaros Desktop works good and flawlessly on Slackware too? That's great. Did you also run the AROS tap networking device and the icaros daemon as well? (hostbridge).

This kind of information is gold to me.

Posted on: 2/1 2:02
_________________
p.bes
Icaros Desktop AROS distribution mantainer
Transfer the post to other applications Transfer


Re: AROS hosted

Joined:
2004/4/7 4:26
Group:
Member
Posts: 4375
Offline
Quote:

elwis wrote:
Baah, I did a fresh reinstall according to that guide: http://amifreak.ftp.sh/post/setting-up-environment-to-start

But X really hates me and my Ubuntu.

Quote:

[ELF Loader] Code 0xf3a32ccc, Data 0x8d8ed24, Module ram-handler...
[Bootstrap] Entering kernel at 0xf391b000...
XError 8 (Major=73, Minor=0) task = X11
BadMatch (invalid parameter attributes)


I had already seen the 'ram-handler' error in task x11 and I guess you're simply doing something wrong. Try running AROSBootstrap from the /linux/boot subdirectory and don't forget to add the -m xxx parameter. It specifies the amount of RAM you'd like to reserve to your AROS layer.

The other option, simply put, is downloading and installing Icaros Desktop in hosted mode. It configures itself on supported distributions (Debian derived ones) and you shouldn't have any further hassle to run it.

Posted on: 2/1 3:40
_________________
p.bes
Icaros Desktop AROS distribution mantainer
Transfer the post to other applications Transfer


Re: AROS hosted

Joined:
2012/8/16 12:52
From Sweden
Group:
Member
Posts: 97
Offline
Quote:

paolone wrote:

I had already seen the 'ram-handler' error in task x11 and I guess you're simply doing something wrong. Try running AROSBootstrap from the /linux/boot subdirectory and don't forget to add the -m xxx parameter. It specifies the amount of RAM you'd like to reserve to your AROS layer.


Yep, I'm doing somehting wrong for sure.
I don't have any "boot" directory unfortunately
Quote:

elwis@elwis-Lenovo-V110-15ISK:/opt/aros/system/Arch/linux$ ls
AROSBootstrap AROSBootstrap.conf Devs kernel L Libs
elwis@elwis-Lenovo-V110-15ISK:/opt/aros/system/Arch/linux$

I followed that guide but maybe I downloaded wrong file?

I have tried different options to run /Arch/linux/AROSBootstrap, the guide didn't mention it but I found it elsewhere. No luck with -m 512 though.

Anyway, since I have native AROS machines I can do my testings anyway, just thought it could be smooth to simply copy the programs over. In the other hand, I need to
get familiar with the AROS code anyway so why wait.

Posted on: 2/1 6:13

Edited by elwis on 2018/2/1 6:38:33
Transfer the post to other applications Transfer


Re: AROS hosted

Joined:
2012/8/16 12:52
From Sweden
Group:
Member
Posts: 97
Offline
Well.. he who gives up is.. he's a quitter!!

I did a fresh Debian install and followed this guide:
https://github.com/apiraino/aros_guide

I had to add a bunch of packages (libpng-dev, libasound2-dev and mesa-common-dev)but then it built.

But I still do something wrong when running it, it won't display anything.

Quote:

elwis@debian:/opt/aros/AROS-20180129-source/bin/linux-i386/AROS/Arch/linux$ ./AROSBootstrap -m 512

......
ELF Loader] Code 0xb73cabdd, Data 0x567229e8, Module Libs/utility.library...
[ELF Loader] Code 0xb73cfe3d, Data 0x567229f0, Module L/con-handler...
[ELF Loader] Code 0xb73dc59e, Data 0x567229f4, Module L/ram-handler...
[Bootstrap] Entering kernel at 0xb7228000...
[I2C] Init
Display driver(s) failed to initialize. Entering emergency shell.
EndCLI will quit AROS.


Well, good for me I'm not that quitter!

Posted on: 2/1 12:17
_________________
www.arosos.se
Transfer the post to other applications Transfer


Re: AROS hosted

Joined:
2004/10/30 17:13
From Ireland
Group:
Member
Posts: 2693
Offline
It sounds like you're trying ABIv0. Please try ABIv1 as an experiment, because I fixed a race condition in starting the AROS X driver at Christmas.

Posted on: 2/1 15:32
Transfer the post to other applications Transfer


Re: AROS hosted

Joined:
2012/8/16 12:52
From Sweden
Group:
Member
Posts: 97
Offline
Thanks and yes i was trying v0. I grabbed v1 instead and got another kind of errormessage, this one might be easier to google. Looks like I'm missing some xcursor lib (I do have libxcursor1 and libxcursor-dev installed)

Gyuess its a 64/32 problem, as always

Quote:

[ELF Loader] Code 0xb7386ea9, Data 0x572034c4, Module Libs/utility.library...
[ELF Loader] Code 0xb738b025, Data 0x572034cc, Module L/con-handler...
[ELF Loader] Code 0xb7394c26, Data 0x572034d0, Module L/ram-handler...
[Bootstrap] Entering kernel at 0xb7228000...
[KRN] Protecting host process stack (0xff9d71a0 - 0xff9e11a0)
[X11host] x11_hostlib_load_so: failed to open 'libXcursor.so.1': libXcursor.so.1: cannot open shared object file: No such file or directory
[I2C] Init
Display driver(s) failed to initialize. Entering emergency shell.
EndCLI will quit AROS.


Posted on: 2/1 22:11
_________________
www.arosos.se
Transfer the post to other applications Transfer



(1) 2 »



You can view topic.
You cannot start a new topic.
You cannot reply to posts.
You cannot edit your posts.
You cannot delete your posts.
You cannot add new polls.
You cannot vote in polls.
You cannot attach files to posts.
You cannot post without approval.

[Advanced Search]


Search
Top Posters
1 paolone
paolone
4375
2 magorium
magorium
4095
3 phoenixkonsole
phoenixkonsole
3897
4 nikolaos
nikolaos
3761
5 deadwood
deadwood
2923
6 ncafferkey
ncafferkey
2693
7 mazze
mazze
2216
8 clusteruk
clusteruk
2111
9 Kalamatee
Kalamatee
2026
10 damocles
damocles
1789
© 2004-2017 AROS Exec